Определение даты из произвольной строки

Публикация № 1241070

Разработка - Практика программирования

Определение даты дата из строки парсинг документа

Описанная функция получает дату из произвольной строки.

Здесь описана функция получения даты из произвольной строки, реализована с целью выявления даты из ячейки счета-фактуры например: 

  • Счет-фактура №  087-103-5-0014375  от 25.05.20  (1)                                                            
  • Счет-фактура №  087-103-5-0014375  от 25 января 2020 года        

Реализован принцип поиска в строке чего-то похожего на дату. Из всех найденных возможных дат возвращается самая адекватная.

Принцип взят как составления наборов частей дат разделенных пробелами либо разделителями типа ",;/.-\ " начиная с конца, год + месяц + день

Алгоритм не распознает "что угодно" и если сунуть ему хаос из наборов букв и цифр то он ничего не распознает или распознает не верно

Например: 0102523 18мая 2020 3689832 12/12/2020 12\05\2021\  распознается как 12 декабря 2020 года

0102523 18 мая 2020 3689832 12/12/2020 12\05\2021\  распознается как 18 мая 2020 года

Т.к. во входящих документах обычно все же есть какая то логика алгоритм обрабатывает 100% входящих дат, за время работы ошибок не выявлено.

 

Здесь приведен код распознавания:

Функция Вернутьдату(Строка)
	Имена = новый Структура;
	Имена.Вставить("ЯНВАРЬ", 1);
	Имена.Вставить("ФЕВРАЛЬ",2);
	Имена.Вставить("МАРТ", 3);
	Имена.Вставить("АПРЕЛЬ", 4);
	Имена.Вставить("МАЙ", 5);
    Имена.Вставить("МАЯ", 5);
	Имена.Вставить("ИЮНЬ", 6);
	Имена.Вставить("ИЮЛЬ", 7);
	Имена.Вставить("АВГУСТ", 8);
	Имена.Вставить("СЕНТЯБРЬ", 9);
	Имена.Вставить("ОКТЯБРЬ", 10);
	Имена.Вставить("НОЯБРЬ", 11);
	Имена.Вставить("ДЕКАБРЬ", 12);
	
	Имена.Вставить("ЯНВАРЯ", 1);
	Имена.Вставить("ФЕВРАЛЯ",2);
	Имена.Вставить("МАРТА", 3);
	Имена.Вставить("АПРЕЛЯ", 4);
	Имена.Вставить("ИЮНЯ", 6);
	Имена.Вставить("ИЮЛЯ", 7);
	Имена.Вставить("АВГУСТА", 8);
	Имена.Вставить("СЕНТЯБРЯ", 9);
	Имена.Вставить("ОКТЯБРЯ", 10);
	Имена.Вставить("НОЯБРЯ", 11);
	Имена.Вставить("ДЕКАБРЯ", 12);


    МасСтрок = _РазбитьСтроку(Строка,",;/.-\ ");
	
	МасЦифр = Новый Массив;
	
	МасВозврата = Новый ТаблицаЗначений;
	КД = новый КвалификаторыДаты(Частидаты.Дата);
	МКв = новый Массив();
	Мкв.Добавить(Тип("Дата"));
	МасВозврата.Колонки.Добавить("датаОп", Новый ОписаниеТипов(МКв,,КД));
	
	Для каждого стр из МасСтрок Цикл
		НЗ = "";
		СтрПроверки = УбратьСпецСимволыРус(ВРЕГ(СокрЛП(стр)));
		ПС = Лев(СтрПроверки,1);
		Если НЕ ТолькоЦифры(СтрПроверки) и НЕ ТолькоЦифры(ПС) Тогда
			Если Имена.Свойство(СтрПроверки, НЗ) Тогда
				МасСтрок[МасСтрок.найти(СтрПроверки)] = НЗ;
			КонецЕсли;
		Иначе
			НЗ = стр;
		КонецЕсли;
		НовЦифра = "";
		Для аа=1 по СтрДлина(НЗ) Цикл
			  Сим = Сред(НЗ,аа,1);
			  Если ТолькоЦифры(Сим) Тогда
				  НовЦифра = НовЦифра + Сим;
			  КонецЕсли;
			  
		КонецЦикла;
		Если ЗначениеЗаполнено(НовЦифра)Тогда
			МасЦифр.Вставить(0,НовЦифра);
		КонецЕсли;
		
		
	КонецЦикла;
	
	Если МасЦифр.Количество()<3 Тогда
		Возврат Дата('00010101');
	КонецЕсли;
	
	Активно = истина;
	Пока Активно Цикл
		Если МасЦифр.Количество()<3 Тогда
			прервать;
		КонецЕсли;
		
		Если СтрДлина(МасЦифр[0])<4 Тогда
			Год = "000" + МасЦифр[0];
			Год = Прав(Год,3);
			Год = "2" + Год;
			
		ИначеЕсли СтрДлина(МасЦифр[0])>4 Тогда
			МасЦифр.Удалить(0);
            Продолжить;
		Иначе
			Год = МасЦифр[0];
		КонецЕсли;
		
		Если СтрДлина(МасЦифр[1])<2 Тогда
			Месяц = "0" + МасЦифр[1];
		ИначеЕсли СтрДлина(МасЦифр[1])>2 или Число(МасЦифр[1])>12 Тогда
			МасЦифр.Удалить(0);
			Продолжить;
		Иначе
			Месяц = МасЦифр[1];
		КонецЕсли;
		
		Если СтрДлина(МасЦифр[2])<2 Тогда
			День = "0" + МасЦифр[2];
		ИначеЕсли СтрДлина(МасЦифр[2])>2 или Число(МасЦифр[2])>31 Тогда
			МасЦифр.Удалить(0);
			Продолжить;
		Иначе
			День = МасЦифр[2];
		КонецЕсли;
	
		
		
		СтрокаДля = Год  + Месяц + День;
		
		Попытка
			датаВозвр = дата(СтрокаДля);
			Доб = МасВозврата.Добавить();
			доб.ДатаОп = датаВозвр;
			МасВозврата.Добавить(датаВозвр);
			МасЦифр.Удалить(0);
		Исключение
			МасЦифр.Удалить(0);
		КонецПопытки;
		
	КонецЦикла;
	
	
	Если МасВозврата.Количество() > 1 Тогда
		
		Запрос = Новый Запрос;
		Запрос.Текст = 
		"ВЫБРАТЬ
		|	даты.ДатаОп
		|ПОМЕСТИТЬ ДОпр
		|ИЗ
		|	&даты КАК даты
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	МИНИМУМ(ВЫБОР
		|			КОГДА РАЗНОСТЬДАТ(ДОпр.ДатаОп, &ТД, ДЕНЬ) < 0
		|				ТОГДА -РАЗНОСТЬДАТ(ДОпр.ДатаОп, &ТД, ДЕНЬ)
		|			ИНАЧЕ РАЗНОСТЬДАТ(ДОпр.ДатаОп, &ТД, ДЕНЬ)
		|		КОНЕЦ) КАК Поле1,
		|	ДОпр.ДатаОп
		|ПОМЕСТИТЬ Вт2
		|ИЗ
		|	ДОпр КАК ДОпр
		|
		|СГРУППИРОВАТЬ ПО
		|	ДОпр.ДатаОп
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	МИНИМУМ(Вт2.Поле1) КАК Поле1
		|ПОМЕСТИТЬ ВТМИН
		|ИЗ
		|	Вт2 КАК Вт2
		|;
		|
		|////////////////////////////////////////////////////////////////////////////////
		|ВЫБРАТЬ
		|	Вт2.ДатаОп,
		|	ВТМИН.Поле1,
		|	Вт2.Поле1 КАК Поле11
		|ИЗ
		|	Вт2 КАК Вт2
		|		ВНУТРЕННЕЕ СОЕДИНЕНИЕ ВТМИН КАК ВТМИН
		|		ПО Вт2.Поле1 = ВТМИН.Поле1";
		
		Запрос.УстановитьПараметр("Даты",МасВозврата);
		Запрос.УстановитьПараметр("ТД", Текущаядата());
		
		Рез = Запрос.Выполнить().Выгрузить();
		
		Возврат Рез[0].ДатаОп;
				
			
	ИначеЕсли МасВозврата.Количество() = 1 Тогда
		Возврат МасВозврата[0].датаОп;
	Иначе
		Возврат Дата('00010101');
	КонецЕсли;
КонецФункции

Функции РазбитьСтроку, ТолькоЦифры и УбратьСпецСимволы можно написать самому или взять в приложенной обработке

 

Обработка выполнена на обычной форме под платформой 1С:Предприятие 8.3 (8.3.16.1296)

Процедуры и функции используются в модуле управляемой формы &НаСервере

Скачать файлы

Наименование Файл Версия Размер
Определение даты из произвольной строки

.epf 8,29Kb
25.05.20
2
.epf 8,29Kb 2 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    46640    156    ekaruk    32    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    23579    22    Stepa86    45    

Вам нравятся запросы в 1С?

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    19739    4    m-rv    86    

Отправка электронной почты с помощью локального почтового клиента из 1С, развернутой под удаленным рабочим столом

Печатные формы документов Универсальные функции Email v8 КА1 БП2.0 УТ10 УПП1 Абонемент ($m)

Решение для интерактивной (нажал-отредактировал) отправки электронных писем и печатных форм через почтовый клиент (Thunderbird, Outlook) находящийся на локальном компьютере, из конфигурации 1С, развернутой под удаленным рабочим столом (RDP, remote-app). Подходит также для локального развертывания 1С. Представлен пример быстрой интеграции с конфигурациями "Управление торговлей 10.3", "Управление производственным предприятием 1.3", "Комплексная автоматизация 1.1", "Бухгалтерия предприятия 2.0".

1 стартмани

21.09.2018    23769    16    stvorl    0    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    29814    86    m-rv    57    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    21107    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    35659    54    dsdred    15    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    27348    26    informa1555    26    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    27551    19    mvxyz    17    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    45264    17    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    29848    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    26437    51    kwazi    6    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    26981    69    vasvl123    9    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    43452    12    swimdog    41    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    31600    132    PLAstic    59    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    22176    21    sasha777666    63    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    50646    35    ildarovich    41    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    125937    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    30709    112    romasna    49    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    27980    123    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    21440    104    Alxby    23    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    24831    16    Anton64    22    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    35995    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    26031    134    Stepa86    15    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    47436    36    Demanoidos    60    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    27486    76    ZhokhovM    60    

Хранение файлов в томах на диске (для УПП 1.3)

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    56134    8    wowik    32    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    59950    177    rozer    64    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    56669    19    arakelyan    18    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    33845    48    ildarovich    23    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    79177    155    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    17770    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    48958    50    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    53537    173    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    22733    8    Tatitutu    5    

Генерация QR-кода программная и интерактивная (код открыт, управляемая форма, обычное и управляемое приложение, API)

Универсальные функции Универсальные обработки v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработку можно быстро и легко интегрировать в любую конфигурацию с и без БСП (Библиотека Стандартных Подсистем).

3 стартмани

04.02.2016    47351    173    TuneSoft    30    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    36551    19    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    55806    47    YPermitin    19    

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    90674    457    Luchik    202    

Автоматическая подстановка уничтожений временных таблиц в текст запроса

Универсальные функции v8 1cv8.cf Абонемент ($m)

Функция, которая сама подставляет в текст запроса "УНИЧТОЖИТЬ" в местах последнего использования ВТ.

1 стартмани

14.11.2015    19976    0    SeiOkami    3    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Практика программирования Разработка внешних компонент Загрузка и выгрузка в Excel v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    194229    441    Zerocl    66